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1. Purpose

This document was created to showcase open data resources available to surveyors. Many Web
Map Services (WMS) are available to the public as open data and can be utilised by surveyors using
an open Geographic Information system (GIS) program, such as QGIS.

2. Disclaimer

This document was prepared for the Board of Surveying and Spatial Information (BOSSI) Spatial
Information Committee for the purpose of disseminating information to benefit the public. It builds
upon work contributed by Spatial Information Committee members Gabriel Van Wyk, Roshni
Sharma, Brittany Baker and the GCA GIS for Surveyors webinar series.

The committee took care to ensure information in this document is correct and accurate as possible
as of 12 September 2023.

The committee does not guarantee and accepts no legal liability arising from, or connected to, the
use of any material contained in this document, or any linked site. The committee recommends
users to exercise their own care with respect to use of this website and that users carefully
evaluate the accuracy, currency, completeness, and relevance of the material in this document for
their purposes. This document is not a substitute for independent professional advice and users
should obtain appropriate professional advice relevant to their circumstances.

QGIS has been used in this documentation as it is a free and open source software. A variety of
commercial alternatives are available and users should choose software that meets their needs.

3. About Open Data

The NSW Government Open Data Policy focuses on datasets as an aspect of information defined in
the Government Information (Public Access) Act 2009 (GIPA Act). A dataset is an identifiable
collection of government-held information or data. Most commonly a dataset refers to a single
database table, a single statistical data matrix, a collection of closely related tables or a subset of
data within a larger dataset.

Data is open to the extent that its management, release and characteristics meet the principles of
openness outlined in this policy. Open data should be both technically available and usable and
have licensing frameworks in place to facilitate its release and use. For further information visit:
https://data.nsw.gov.au/nsw-government-open-data-policy

Web Map Services (WMS) and Web Feature Services (WFS) provide a way of delivering geospatial
data using established internet protocols developed by the Open Geospatial Consortium. WMS and
WMTS services deliver spatial information as map images (for example: JPEG, PNG). WFS services
deliver data in a standard XML format. WMS can be found on any of the following NSW Open Data
Portals, and viewed in a GIS program. Follow the instructions below detailing this process. Further
information can be found in the Appendix.

Online NSW Open Data Portals
e Data.nsw.gov.au
e Spatial Collaboration Portal
e Environmental Data Portal, SEED
e NSW Department of Education
e NSW Health
e Transport for NSW
e NSW Bureau of Crime Statistics and Research
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e NSW Flood Portal
e ePlanning
e State Insurance Regulatory Authority

4. Exemplar Open Data Workflow

Geospatial datasets are critical for modern planning, reporting, and mapping workflows. Surveyors
can use open geospatial data during multiple stages of survey planning and preparation, along with
use cases during development, implementation, and monitoring of a site’s location, environmental
impact mitigation, and infrastructure design. Online web services are one way to access a wealth of
geospatial information available for these workflows. Internet connection is required to follow
these instructions. It is possible to download datasets to use offline in some circumstances, but this
is not covered by this document.

There are detailed instructions for using open data online in three phases:
1. Searching for Open Data Online,
2. Viewing in QGIS, and
3. Loading Shared Files in QGIS.

Searching for Open Data Online
1. Open an internet browser (for example, Chrome or Edge).
2. Navigate to https://www.data.gov.au/home
3. Search for a topic of choice (for example, Acid Sulfate Soils):

Acid sulfate soils

4. Filter the results by format to find geospatially-enabled layers available (WMS, WMTS,
WES, or Esri MapServer). If you are looking to view the data ONLY, select ‘WMS'.
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Acid sulfate soils O,
g Any Organisation ‘ @, Any Location a Any Format H E Any Date
RESULTS (109) | Beal'ch for format Q, ||

Acid Sulfate Soils Risk GEOJSON (17)

ESRI MAPSERVER (17 )

This project has mapped the occurrence of Acid S 1 asgist land management ...

Dataset Updated 28/04/2023 | Linked Data Ratir WMS /[ XML/ KML

KML (14)

Acid Sulfate Soil Potential

5. Select arecord from the results, that matches your requirement and contains a geospatial
Web Service (WMS, WMTS, WFS, or Esri MapServer).

6. Scroll down the record’s page to find the item that matches a web service format:

Web Map Service (WMS)(WMS) ‘__ ~ Download

Creative Commons Attribution

7. Copy the WMS URL. On this website you may either select ‘Download’ to be taken to the
WMS link:

# mapprod3.emvironmentnsw.gov. X +

&« Cc @ mapprod3.environment.nsw.gov.au,/zrcgis/services/So

This XML file does not appear to have any style information associated with it. The document tree 1s shown below.

OR you can click on the item, and be directed to a page with the WMS link:

Open Data Documentation - April 2024 7



Board of Surveying and Spatial Information

Web Map Service (WMS)

Department of Planning and Environment Created 05/09/2018

WMS Creative Commons Attribution

~ Download

No description provided

Source

This data file or API can be downloaded from:
https://mapprod3.environment.nsw.gov.au/arcgis/services/Soil/AcidSulfateSoilRisk Probability/MapServ
er/WMSServer?request=GetCapabilities&service=WMS

8. Keep the copied WMS link handy for the next phase, to view in QGIS.

In this example we will copy:
https://mapprod3.environment.nsw.gov.au/arcgis/services/Soil/AcidSulfateSoilRisk_Probabi
lity/MapServer/WMSServer?request=GetCapabilities&service=WMS

Note this URL could change but is correct at time of document creation. It is recommended
to copy the link directly from the website to ensure it is up to date.

4. Viewing Open Data in QGIS

1. Open QGIS. If you do not have QGIS as an installed program, visit the website to Download
QGIS and install. https://www.qgis.org/en/site/
2. If prompted, open a New Empty Project.

New Empty Project

EPSG:3857 - WGS 84 [/ Pseudo-Mercator

3. To add alayer in QGIS, you must know the data format.
In the previous steps, a WMS was copied. To add this layer, select the ‘Layer’ menu, and

under ‘Add Layer’ > ‘Add WMS/WMTS Layer’.
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(&) Untitled Project — QGIS

Project Edit Wiew QEVEd Settings Plugins Vector Raster Database Web Mesh Progessing Help
D E a Data Source Manager Ctrl+L Q B !3 E
i cm Create Layer » 4 g 5 ;
[, Add Vector Layer.. Ctrl+ Shift+V
'@V oo
a8 Embed Layers and Groups... 'u Add Raster Layer... Ctrl+Shift+R
=a Add from Layer Definition File... m Add Mesh Layer...
E i j:t Georeferencer... ,u Add Delimited Text Layer... Ctrl+Shift+T
Copy Style 'u Add PostGIS Layers... Ctrl+Shift+D
e Y l Paste Style F’b Add SpatiaLite Layer... Ctrl+Shift+L
Bomrss Copy Layer H Add M5 50QL Server Layer...
q e ? ? Paste Layer/Group q Add Oracle Spatial Layer... Ctrl+5Shift+0
: Open Attribute Table = 1%}, Add 5AP HAMNA Spatial Layer...
?"'? Favorites Filter Attribute Table » | B8 Add/Edit Virtual Layer..
v [I" spatial Bookmar Toggle Editing 3 Add WMS/WMTS Layer... Ctrl+Shift+W
» Home B e
@ ) Save Layer Edits ity Add XVZ Layer...
’ D C (indows-5, Current Edits » % Add WCS Layer...
» o A () Add WFS Layer..
» [P Save As.. >
. N ) (7 Add ArcGIS REST Server Layer...
» D S Save As Layer Definition File...
PO T [l Remove Layer/Group Ctrl+D B}, Add Vector Tile Layer..
. N ﬁ Add Point Cloud Layer...
» D ¥ Duplicate Layer(s)
& N . % Add GPX Layer..,
~ no Set Scale Visibility of Layer(s) =
Layers Set CRS of Layer(s) Ctrl+Shift+ C

This will open a new window called ‘Data Source Manager | WMS/WMTS'.

4. Select ‘New’ to open a new window for establishing a connection to the layer.

(2} Data Source Manager | WMS/WMTS — O x
ﬁ Browser Layers | Layer Order Tilessts
L | Acid Sulfste Soiks Risk - |
* Vector
| Comect || mew || Edt || Remove | loed || save |
Raster | Q Create a new service connection Il |
g Mesh ID Name Title Abstract
oint Cloud
Delimited Text
GeoPackage
GPS
Spatialite
Image Encoding
tgreSQL
M5 SOL Server ——
ns
Oracle Tile size | | | |
Virtual Layer Request step size | | | |
A A A Maximum number of GetFeaturelnfo results |].0 |
AP HANA
Coordinate Referance System EPSG:3857 - WGES 84 [ Pseudo-Merc ™
Use contesctusl WMS Legend

5. Inthe ‘Create a New WMS/WMTS Connection’ window, paste in the URL into the ‘URL’ box,
and type in a name for the layer. Click OK.
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* Create a New WMS/WMTS Connection >

‘Connection Details

Name | Acid Sulfate Soils |

URL https:/{mapprod3.environment.nsw.gov.au/arcgis/services/ Soil/ AcdSulfateScilRisk_Probal
ttps PP g reg 2

6. Then click on ‘Connect’. This will establish a connection to the online web service layer.

layers | LeyerOrdsr | Tiessts

| Acid Sulfste Soils - |
Connet || MNew || Edit || Remove | load || sawe |
D ~ MName Title Abstract
* 0 Layers
»o1 0 Areas This project has mapped the occurrence of Ac...
»o3 1 Boundaries This project has mapped the cccurrence of Ac..
» 5 2 Labels This project has mapped the cccurrence of Ac..

7. Click on alayer from the list generated after connecting. If you wish to load all information
onto the map interface, select the top layer (i.e. ID 0). Then select ‘PNG’ as the image
encoding option and select ‘Add’ at the bottom of the screen.

18] + Mame Title Abstract
L 0 Areas This project has mapped the occurrence of Ac... B
» 3 1 Boundaries This project has mapped the occurrence of Ac...
» 5 2 Labels This project has mapped the occurrence of Ac... | ||
Image Encoding
(® PNG 9 (JVIPEG () GIF () TIFF () WG
Options
| [ |
Aot 2 | | |
Maximum number of GetFeaturzInfo results |10 |
Coordinate Reference System (4 available) | EPSG:3857 - WGS 84 [ Pssudo-Menc ¥ | |§|
Use contextual WMS Legend

ayer name | Areas/Boundaries/Labels |

Load as separste layers

Lzyer(s) selected
Cese || add Hep |

|Add selected layers to mapi

Open Data Documentation - April 2024 10



Board of Surveying and Spatial Information

8. The layer has now been added to the map. Select ‘Close’ if the window is still open to view
your layer on the map. Zoom in to view data and add more layers to provide more content.

(2 *Untitled Project — QGIS
Project Edit View Layer Settings Plugins Vector Raster Database Web [Mesh Processing Help

DEARRY UPL2LHAINPRPLA S EALIOR & %1
A@V.ZwEW =
=, &~ AN Ty VT ¢
<] %4 0B% RERPV;-

Browser
ASTHO

Favorites
' Spatial Bockmarks qfs’f
| Home N
[ 7] ¢\ (Windows-55D)
[0
[T e
[ sa
71 >
v
i s LW
Layers (5] 7 i,{.f‘

& @ @ ?' B A

~ |v| B Areas/Boundaries/Labels

ASS probability of cccurrence

B

[

[

[

[
“-e‘.’.‘% .

[

]
]
]
»
»
]
]
]

Hm: High probability in bottom sediments

0: High probability at/near ground suface
M Hois ) Hi ity at/near ground surface wit
[ | Lability <1 m below ground surface

B HA1i=v Hinh reakahilie <1 mkaloase aronnd = ofac

5. Loading Shared Files in QGIS

There are many ways to share geospatial open data in and between QGIS. Two common ways
include sharing a QGIS project file (.ggz) or an XML file to load web services (.xml).

Using a QGIS Project File

1. Open QGIS. If you do not have QGIS as an installed program, visit the website to Download
QGIS. https://www.ggis.org/en/site/

2. Install.
3. Select ‘Project’ > ‘Open’, to open the provided .ggs file.

4. View the map interface to access the data services shared in the QGIS project file. Explore
the available layers by selectively enabling or disabling (ticket box) in the layers list panel.
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v ful Survey
|.E|'_-.-'-EI'E » ¥ SurveyMark
~ [v] [l Cadastre
« 0 ® T, - W ~ V| I Lot _Labels
’ [l Survey * V| ¥ Lot
g m Cadastre M ¥ SectionExtent
v ¥ [l Background

hd ¥ Rural_PlanExtent

~ W ¥ PlanExtent

hd - Large Rural PlanExtent
> ] [ Background

v ¥ public NSW Imagery

Vertex Editor Statistics | Layers | Browser + V| % public NSW Topo Ma

7. Loading an XML File of Web Services

1. Open QGIS. If you do not have QGIS as an installed program, visit the website to Download
QGIS and install. If prompted, open a ‘New Empty Project’.

New Empty Project

EPSG:3857 - WGS 84 / Pseudo-Mercator

2. Select the ‘Layer’ menu and under ‘Add Layer’ > ‘Add WMS/WMTS Layer’.

() Untitled Project — QGIS

Project Edit View QEVEY Settings Plugins  Vector Raster Database Web Mesh Progessing  Help

= =] ﬂ Data Source Manager Ctrl+L i i
N B DR P RLES G
(= Create Layer 4 . :
g % vo W7 Add Vector Layer... Ctrl+ Shift+V
(o] Embed Layers and Groups... 'o Add Raster Layer... Ctrl+Shift+R
= Add from Layer Definition File... ﬂ', Add Mesh Layer...
E ; j:t Georeferencer.., ’0 Add Delimited Text Layer... Ctrl+Shift+T
V‘J l Copy Style .o Add PostGIS Layers... Ctrl+Shift+D
e Paste Style f’o Add Spatialite Layer... Ctrl+Shift+L
I — Copy Layer R Add M5 SQL Server Layer...
q g ? 1 Paste Layer/Graup % Add Oracle Spatial Layer... Ctrl+Shift+ O
Open Attribute Table E6 1M, Add SAP HAMA Spatial Layer..,
' Favorites Filter Attribute Table | 4 Add/Edit Virtual Layer..
» " Spatial Bookmar Toggle Editing &3 Add WMS/WMTS Layer... Ctrl+Shift+ W
4 Home B HH
R % A (Wind s Save Layer Edits #ip Add XYZ Layer..,
N\ (Windows-5§
, . Current Edits 4 % Add WCS Layer...
0 oa Save As (] Add WFS Layer...
» D P Save As... -
B S ) &7 Add ArcGIS REST Server Layer..,
b D 5 Save As Layer Definition File...
P [} Remove Layer/Group Ctrl+D B, Add Vector Tile Layer..
) . 94 Add Point Cloud Layer...
» D ¥, Duplicate Layer(s)
& R . &3 Add GPX Layer...
o Set Scale Visibility of Layer(s)
| Layers Set CRS of Layer(s) Ctrl+Shift+C

This will open a new window called ‘Data Source Manager | WMS/WMTS'.
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3. Select ‘Load’ to open a new window for loading in the XML file of web services.

Layers | Layer Order | Tilesels

Acid Sulfste Sail \ 2 |
Connect | New | Edit Remove Load Save
| D ~ MName Title Abstract |

4. You will be prompted to select the web services from the file. If you wish to load all, please
select ‘Select All’, and then ‘Import’.

(5} Manage Connections XK

Select connections to import

Acid Sulfate Soils Risk =
Administrative Boundary

BiodiversityValues

Boreholes

Cadastre History

Commonwealth_Heritage _List

Development Control

EPI Additional Layers

EP| Development Control Layers

EPI Land Use Layers

EPI Primary Planning Layers

Hazard

Keoala Habitat |
MNSW 5M Elevation |
NSW Administrative Boundaries

Import Salact All Clear Salection Close

5. Select aloaded layer to display on the map by clicking on the drop down list of layers now
available.

Layers Layer Order Tilesets

Arid Sulfzte Soils

Acid Sulfate Soils Risk
Administrative Boundary
Background
BiodiversityWzlues

Boreholes

Cadastre History
Commonwealth_Heritage_List
EPI Additional Layers

EPI Development Control Layers

EPI Land Use Layers

6. Once alayer is selected, click on ‘Connect’. This will establish a connection to the online web
service layer. Then click on a layer from the list generated after connecting. To load all
information onto the map interface, select the top layer (ID 0). Then select ‘PNG’ as the
image encoding option and select ‘Add’ at the bottom of the screen.
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Image Encoding

Options

() PNG ea wee (aF ()

Development Control

| Development Control - |
| comect ||  mew || Edit [| Remove | toad ||  sawe |
| Q
I ~ MName Title Abstract
* 0 Layers

L

Tie sie |

Request step size |

Maximum number of GetFeaturelnfo results

Coordinate Reference System (3 available)

Use contextual WMS Legend

|10

| EPSG:4283 - GDAS4

kY

Layer name |ﬁnnstreenﬁeld Housing Code AreafLocal Provisions/ Active Strest Frontages/ Additional Permitted Usas/Key Sites/Urban Releass Areal

Load as separate layers
7 Layer(s) selected

7. Your layer has now been added to the map. Select ‘Close’ if the window is still open to view

your layer on the map. Zoom in to view data and add more layers to provide more content.

Browser

LEST*O

hicd i
7. Favorites

4 J' Spatial Bookmarks

@®

~

V\é}

> @ Home [j
» [ c (Windows-55D)
r [Jon
y [ =
r [
y [ ™
» 07w _ m
o o -
Layers =] rj --
« B® TV -B AL N 2
v W :l. Special Infrastructure Contributions/Greenfield Housit =
a
v :l. Areas/Boundaries/Labels
ASSE probability of occurrence
I Hm: High probability in bottom sedim ents
W Ho: High probability atnear ground s uface
W Hois): High probability at'near ground surface with acidic scalds
W H1: Highprobability <1 m below ground surface
! .HT:S.:I_:_ I-.|igh Pm??l?il'rt.}' -=_1 m.bPTIow grounf:l 5urfac:ew'rth acidic sc Ll ’)7
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8. Appendix - About Open Data

Further Resources
e NSW Data Policy: https://data.nsw.gov.au/data-policy
e Open Data Handbook: https://opendatahandbook.org/guide/en/what-is-open-data/
e Open Data Institute: https://www.theodi.org/topic/geospatial-data/
e Open Data Course: https://data.europa.eu/elearning/en/#/id/co-01
e Report on the State of Open Data: https://www.stateofopendata.od4d.net/
e The Open Data Charter (https://opendatacharter.net/)
e OGC: Open Geospatial Consortium
o royalty free, publicly available, open geospatial standards
o https://www.ogc.org/docs/is
o Best Practices Schema Repository
e The Australian government policy on Public Data
e GIS Guide to Public Domain: https://www.esri.com/en-us/esri-press/browse/the-gis-guide-
to-public-domain-data
e Geoprivacy: https://onlinelibrary.wiley.com/doi/abs/10.1111/tgis.12305
e Check your dataset is FAIR with the handy self-assessment tool:
https://ardc.edu.au/resource/fair-data-self-assessment-tool/
¢ Watch the FAIR data webinar playlist:
https://www.youtube.com/playlist?list=PLG25fMbdLRa700MmUQruKudO__YNFclc?2
e Access free online FAIR data training and resources: https://ardc.edu.au/resource/fair-data-
training-resources/
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